Electronics & Programming

develissimo

Open Source electronics development and programming

  • You are not logged in.
  • Root
  • » GTK+
  • » gtk-2.8.7 - missing pangoft2 in configure [RSS Feed]

#1 Nov. 26, 2005 02:09:36

Scott D.
Registered: 2009-11-02
Reputation: +  0  -
Profile   Send e-mail  

gtk-2.8.7 - missing pangoft2 in configure


I'm not sure if this is a gtk bug or a pilot error, but I had difficulties
configuring gtk-2.8.7; and in particular there appears to be a missing
reference to the pangoft2 library.

After I installed, cairo-1.0, pango-1.10.1 , glib-2.8.4, and atk-1.10.1 on
my semi-customized FC3 box I attempted to configure gtk-2.8.7, but
encountered this failure:

------------
checking Pango flags... -I/usr/local/include/pango-1.0
-I/usr/local/include/glib-2.0 -I/usr/local/lib/glib-2.0/include
-I/usr/local/include/cairo -L/usr/local/lib -lpangocairo-1.0 -lpango-1.0
-lcairo -lgobject-2.0 -lgmodule-2.0 -ldl -lglib-2.0
configure: error:
*** Can't link to Pango. Pango is required to build
*** GTK+. For more information seehttp://www.pango.org------------

After some poking around I determined that configure failed to include
pangoft2. I didn't see any specific gtk-2.8.7 configure options for
customizing pango, so I dove write into the gory configure script and
changed line 31537 from

PANGO_PACKAGES="pango pangocairo"

to

PANGO_PACKAGES="pango pangocairo pangoft2"

and the problem was solved.

Note, I didn't attempt to re-run autoconf, etc...

Scott
_______________________________________________
gtk-list mailing list
gtk-list@gnome.orghttp://mail.gnome.org/mailman/listinfo/gtk-list

Offline

  • Root
  • » GTK+
  • » gtk-2.8.7 - missing pangoft2 in configure [RSS Feed]

Board footer

Moderator control

Enjoy the 27th of April
PoweredBy

The Forums are managed by develissimo stuff members, if you find any issues or misplaced content please help us to fix it. Thank you! Tell us via Contact Options
Leave a Message
Welcome to Develissimo Live Support